<?xml version="1.0" encoding="UTF-8"?><rss xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:atom="http://www.w3.org/2005/Atom" version="2.0"><channel><title><![CDATA[Custom SSL certificate or CloudFlare proxy]]></title><description><![CDATA[<p dir="auto">I installed FusionAuth on dedicated linux server.<br />
Is there any option to use my ssl certificate to secure communication with FusionAuth app? By default its "Inversoft Self-signed root certificate Expired: Wednesday, 25 September 2013 "<br />
And I can't change default port 9013 in option "fusionauth-app.https-port=9013" to 443. App just doesn't start. So I can't use cloudFlare proxy.</p>
]]></description><link>https://fusionauth.io/community/forum/topic/130/custom-ssl-certificate-or-cloudflare-proxy</link><generator>RSS for Node</generator><lastBuildDate>Tue, 15 Sep 2026 18:59:52 GMT</lastBuildDate><atom:link href="https://fusionauth.io/community/forum/topic/130.rss" rel="self" type="application/rss+xml"/><pubDate>Fri, 29 May 2020 09:33:15 GMT</pubDate><ttl>60</ttl><item><title><![CDATA[Reply to Custom SSL certificate or CloudFlare proxy on Fri, 29 May 2020 14:14:22 GMT]]></title><description><![CDATA[<blockquote>
<p dir="auto">And I can't change default port 9013 in option "fusionauth-app.https-port=9013" to 443. App just doesn't start</p>
</blockquote>
<p dir="auto">What error messages, if any, are you seeing in the logs when you try to start it? I was able to change the port to 4000 in a local instance and the app started. Are you starting FA using the root user, because when I changed SSL to run on 443, I saw this error:</p>
<blockquote>
<p dir="auto">29-May-2020 14:03:41.466 SEVERE [main] org.apache.catalina.core.StandardService.initInternal Failed to initialize connector [Connector[HTTP/1.1-443&rsqb;&rsqb;<br />
...<br />
Caused by: java.net.BindException: Permission denied</p>
</blockquote>
<p dir="auto">If you are seeing that in your Tomcat log files, you'll need to start tomcat as root or use a tool like jsvc to do so. Or you can just run the SSL listener on a port above 1024, like 9013.</p>
<blockquote>
<p dir="auto">Is there any option to use my ssl certificate to secure communication with FusionAuth app? By default its "Inversoft Self-signed root certificate Expired: Wednesday, 25 September 2013 "</p>
</blockquote>
<p dir="auto">You can do so by installing your own certificate in Tomcat. This is not something I've done before, but these instructions look helpful: <a href="https://tomcat.apache.org/tomcat-8.5-doc/ssl-howto.html" rel="nofollow ugc">https://tomcat.apache.org/tomcat-8.5-doc/ssl-howto.html</a></p>
]]></description><link>https://fusionauth.io/community/forum/post/299</link><guid isPermaLink="true">https://fusionauth.io/community/forum/post/299</guid><dc:creator><![CDATA[dan]]></dc:creator><pubDate>Fri, 29 May 2020 14:14:22 GMT</pubDate></item></channel></rss>