<?xml version="1.0" encoding="UTF-8"?><rss xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:atom="http://www.w3.org/2005/Atom" version="2.0"><channel><title><![CDATA[Azure Postgres 15.8 Installation Failure Due to Disabled MD5 Function]]></title><description><![CDATA[<p dir="auto">I've created an issue and am posting here for visibility: <a href="https://github.com/FusionAuth/fusionauth-issues/issues/2891" rel="nofollow ugc">https://github.com/FusionAuth/fusionauth-issues/issues/2891</a></p>
<h1>Description</h1>
<p dir="auto">New deployments of the latest FusionAuth (1.53.2) are failing on Azure Database for PostgreSQL Flexible Server version<br />
15.8 with the error below.</p>
<p dir="auto">Note that Azure does not allow specifying minor versions of Postgres, and auto-upgrades all PostgreSQL Flexible Servers to the latest minor release, potentially breaking existing installations.</p>
<pre><code>fusionauth-86b55b4f87-d9xgs fusionauth -- Initialize migrations so they don't run on new installs                                                                    │
│ fusionauth-86b55b4f87-d9xgs fusionauth INSERT INTO migrations (name, run_instant)                                                                                    │
│ fusionauth-86b55b4f87-d9xgs fusionauth   VALUES ('io.fusionauth.api.migration.guice.Migration_1_8_0', 0),                                                            │
│ fusionauth-86b55b4f87-d9xgs fusionauth     ('io.fusionauth.api.migration.guice.Migration_1_9_2', 0),                                                                 │
│ fusionauth-86b55b4f87-d9xgs fusionauth     ('io.fusionauth.api.migration.guice.Migration_1_10_0', 0),                                                                │
│ fusionauth-86b55b4f87-d9xgs fusionauth     ('io.fusionauth.api.migration.guice.Migration_1_13_0', 0),                                                                │
│ fusionauth-86b55b4f87-d9xgs fusionauth     ('io.fusionauth.api.migration.guice.Migration_1_15_3', 0),                                                                │
│ fusionauth-86b55b4f87-d9xgs fusionauth     ('io.fusionauth.api.migration.guice.Migration_1_30_0', 0),                                                                │
│ fusionauth-86b55b4f87-d9xgs fusionauth     ('io.fusionauth.api.migration.guice.Migration_1_42_0', 0);                                                                │
│ fusionauth-86b55b4f87-d9xgs fusionauth .  Cause: org.postgresql.util.PSQLException: ERROR: could not compute MD5 hash: disabled for FIPS                             │
│ fusionauth-86b55b4f87-d9xgs fusionauth 2024-09-27 08:35:30.978 PM INFO  com.inversoft.maintenance.db.JDBCMaintenanceModeDatabaseService - [6ZLRZw] Attempting to unl │
│ fusionauth-86b55b4f87-d9xgs fusionauth 2024-09-27 08:35:30.979 PM INFO  com.inversoft.maintenance.db.JDBCMaintenanceModeDatabaseService - [6ZLRZw] Unlock completed  │
│ fusionauth-86b55b4f87-d9xgs fusionauth 2024-09-27 08:35:31.183 PM INFO  io.fusionauth.api.configuration.DefaultFusionAuthConfiguration - Loading FusionAuth configur │
│ fusionauth-86b55b4f87-d9xgs fusionauth 2024-09-27 08:35:31.183 PM INFO  io.fusionauth.api.configuration.DefaultFusionAuthConfiguration - Dynamically set property [f │
│ fusionauth-86b55b4f87-d9xgs fusionauth 2024-09-27 08:35:31.183 PM INFO  com.inversoft.configuration.BasePropertiesFileInversoftConfiguration -                       │
│ fusionauth-86b55b4f87-d9xgs fusionauth   - Overriding default value of property [database.mysql.enforce-utf8mb4] with value [true]                                   │
│ fusionauth-86b55b4f87-d9xgs fusionauth   - Overriding default value of property [FUSIONAUTH_APP_RUNTIME_MODE] with value [production]                                │
│ fusionauth-86b55b4f87-d9xgs fusionauth   - Overriding default value of property [SEARCH_TYPE] with value [database]
</code></pre>
<p dir="auto">Calling the postgres md5 function produces the same error:</p>
<pre><code>SELECT MD5('PostgreSQL MD5');
ERROR:  could not compute MD5 hash: disabled for FIPS
</code></pre>
<p dir="auto">This error appears to be caused by <a href="https://learn.microsoft.com/en-us/azure/postgresql/flexible-server/release-notes#release-september-2024:~:text=Support%20for%20MD5%20is%20disabled%20in%20favor%20of%20SCRAM%20authentication%20authentication%20for%20new%20PostgreSQL%2014%2B%20new%20server%20deployments." rel="nofollow ugc">Microsoft disabling MD5 support in Azure Postgres 15.8</a>.</p>
<p dir="auto">FusionAuth appears to use the Postgres MD5 function for primary key creation and other non-password hashes. See: <a href="https://files.fusionauth.io/products/fusionauth/1.53.2/fusionauth-database-schema-1.53.2.zip" rel="nofollow ugc">fusionauth-database-schema-1.53.2.zip</a></p>
<p dir="auto">I have created an Azure support ticket, but the official reply from Microsoft is:</p>
<p dir="auto">The MD5 postgres function is now unsupported and it's not possible to deploy previous versions of Azure Postgres Flexible Server which support the MD5 function.</p>
<p dir="auto">If anyone is aware of any workarounds, please reply!</p>
]]></description><link>https://fusionauth.io/community/forum/topic/2777/azure-postgres-15-8-installation-failure-due-to-disabled-md5-function</link><generator>RSS for Node</generator><lastBuildDate>Tue, 08 Sep 2026 03:58:12 GMT</lastBuildDate><atom:link href="https://fusionauth.io/community/forum/topic/2777.rss" rel="self" type="application/rss+xml"/><pubDate>Mon, 30 Sep 2024 19:30:43 GMT</pubDate><ttl>60</ttl></channel></rss>