No suitable driver found for jdbc:mysql://localhost:3306/login?...



  • Hello.

    I am trying to install FusionAuth on a Centos 8 system using MySQL 5.7.30-33 - Percona Server. After starting the setup wizard, adding the db data, I get the FusionAuth is starting page, but then it gets back to the page to enter database data, with the following error:

    The database and schema exist, but for some reason the ordinary user you specified cannot connect to it. Perhaps the user already existed and you provided the wrong password. The error from the database was [No suitable driver found for jdbc:mysql://localhost:3306/login?serverTimezone=UTC&useSSL=false&allowPublicKeyRetrieval=true].

    I verified that the database tables have been created.

    Any help would be appreciated.



  • Hiya,

    Does your server have access to the internet? Due to licensing issues, we don't ship the mysql driver, but instead download it at first use. See the "Network Access" section here: https://fusionauth.io/docs/v1/tech/installation-guide/system-requirements/



  • I just tested this on a fresh virtual machine that has full internet access and this exact same error is occurring.
    Tables were created successfully but fusionauth cannot access the db.
    https://hastebin.com/palixalife.yaml journalctl logs included



  • Thanks for the info, appreciate it!

    Which package are you using to install FusionAuth? I'm guessing the RPM, but can you confirm, please?



  • I'm using the deb package. Fresh Ubuntu 20.04 install



  • OK, I tried to recreate and couldn't.

    How did you install the .deb file? I used dpkg -i <path to deb file>.

    What kind of server were you running on? I tried to use a t2.micro on AWS and it had some issues, I think because it was undersized for running fusionauth. On a t3.large it was fine.

    I used mysql 8, as installed via apt-get. I also tried with percona 5.7, installed per these instructions: https://www.percona.com/doc/percona-server/5.7/installation/apt_repo.html

    So I think I'd need a bit more details to track down your issue.

    • does it occur with mysql 8?
    • does it occur when you install via the zip file?

    Or if you can give me the exact steps you are doing, I can try to replicate that way.



  • I used the install script found at https://fusionauth.io/download/ on a HyperV vm with 2gb of ram allocated.
    The mysql server's version is Server version: 5.7.32-0ubuntu0.18.04.1 - (Ubuntu) on a separate host.
    I'll reinstall the vm and try with mysql8 and the zip files.



    • No suitable driver found for Jdbc:Mysql://localhost:3306


  • @postmaster did you solve the issue?



  • @muralimaxk

    I'm not sure I understand what you are saying. Can you give me a bit more detail?



  • The reason you got this error is because you forgot to register your java mysql jdbc driver with the application.

    Should be like this:

    Class.forName("com.mysql.jdbc.Driver");
    

    This forces the driver to register itself, so that Java knows how to handle those database connection strings.

    You'll have to read the manual on your specific mysql jdbc driver to find the exact string to place inside the the Class.forName("...") parameter.


Log in to reply