Set time server for FusionAuth container



  • We've noticed that after rolling out our container for FusionAuth on Azure Container Groups that we're seeing a slight, multi-second time drift compared to the other containers we have. We're able to correct other containers and point to a central time server with ntp, but I'm not seeing ntp as an option on the default FusionAuth container. Is there a default timeserver setting in the container?



  • Hi @erikh!

    Welcome to the FusionAuth Community!

    I might need more details, as I have only a functional familiarity with Docker and container orchestration. As I understand it, NTP is a service that can be added to your container. But like I said, I might need more context to fully understand your issue. A quick look through the Dockerfile and docker-compose does not show any timeserver options being enabled.

    Any other details about what you have tried, potential pitfalls that you are seeing, or errors may be useful.

    I am also posting here (perhaps perfunctorily), the available documentation on FusionAuth for docker installation:
    https://fusionauth.io/docs/v1/tech/installation-guide/docker/

    The repo supporting FusionAuth containers is here:
    https://github.com/FusionAuth/fusionauth-containers

    The docker files are here as well:
    https://github.com/FusionAuth/fusionauth-containers/blob/master/docker/fusionauth/

    Thanks and let us know. Happy to assist you in resolution as able.

    Thanks!
    Josh


Log in to reply
 

Looks like your connection to FusionAuth Forum was lost, please wait while we try to reconnect.