SOLVED FusionAuth not installing on Google Cloud Platfrom VM Instance

  • Hi. I have been trying to install FusionAuth using Fast Path and manual installation on a Google Cloud Platform VM instance using a single vm database and a separate vm database (MySQL) both running Debian 10. Everytime, the VM will not connect on the browser and once the FusionAuth is started, the SSH connection to the machine is severed somehow, and will not work. I tried to with two versions as well.

    What is it that I could be doing wrong? Is it possible that there is a conflict with the underlying system?

  • @yamkela-spengane

    Are you able to install the database fully by manually running the SQL scripts?

    How much memory does your VM have? What do the logs say? (I'm wondering if java is running out of memory and being killed by the hypervisor. See for a similar issue.)

  • @dan I am able to install the database fully and do all necessary configurations. The problem starts once FusionAuth is installed. The VM has 1GB memory, more than the 512MB required.

    I will review the similar issue you shared, thanks.

  • The issue seems to be memory. I upgraded the VM to be 2GB of Memory, it still had the same problems. It finally worked when I upgraded the VM to be 4GB. It seems that along with the installed NodeJs and MySQL, the memory is quickly maxed out and the system is shut down.

  • Glad you solved it!

    For some reason I thought that the database was on a separate server. Yes, crowding all the applications into limited memory will cause issues. Were you seeing OOM errors in the log files?

  • @dan I had separated the Database from the App, but it didn't work in configuration. So I had to bring it back onto the same server. I will separate the database in production.

  • Ah, great. Yes, if you are running both the database and FusionAuth, you need more memory. If you are running elasticsearch too, you'll need even more.

Log in to reply

Looks like your connection to FusionAuth Forum was lost, please wait while we try to reconnect.