Installation - Error Connecting to Azure Database for PostgreSQL server



  • Hello everyone,

    I am using windows fusion Auth server. Installation was done successfully. Now I am trying to connect it with the Database. I am using Azure Database for PostgreSQL for that.
    When I access the Database using PostgreSQL browser client like pgAdmin 4, I am successfully able to connect with the Postgres database. There are no firewalls on the database to restrict access.

    When I run the Fusion auth server, in maintenance mode, I am trying to connect with DB. I received the following error while connecting it. The error is on the username of the super credentials. (However, username and password are valid as they worked fine while connecting with pgAdmin 4 )

    ErrorFusionAuth.png

    Anyone who faced the similar issue.

    Thank you in advance



  • This is a known issue. There is a workaround for mysql, but I'm not sure about postgresql.

    Here's the relevant issue for you to check out: https://github.com/FusionAuth/fusionauth-issues/issues/681

    Here's the workaround for mysql: https://github.com/FusionAuth/fusionauth-issues/issues/681#issuecomment-644784111



  • Hello,

    Thank you for your reply. I couldn't get it working for my azure Postgres database, errors stays the same, issue with the username.
    However for testing purposes, I installed the local PostgresSQL DB, When I connect the FusionAuth Server with that it worked, I was able to connect with DB and move forward to FusionAuth Dashboard.
    But now I want to attach the Fusion Auth server to my remote Azure Database Again. I can't find the option to do that.
    Can you please highlight the way to change the database from the fusionAuth server(dashboard)?
    Can you please also answer if it is possible to keep different Databases for each tenant?

    Reinstalling(Creating another local instance of Fusion Auth server on the same PC)
    Do I have to reinstall FusionAuth to attach it to another Database? If yes, I actually tried reinstalling FusionAuth in a different directory and I am receiving following error:
    31695ca6-3d84-40db-af66-4bf618b0d343-image.png

    Also, currently, FusionAuth server is installed locally and is running on Localhost, When I want to deploy this do I have to install the fusionAuth again, repeat the process of installing, attaching database, doing all the settings within the fusionAuth server like application creation, or integration of Kafka, or SMTP server configurations again?

    Thank you



  • Hiya!

    You can't change the database URL from the dashboard, you need to do it from the command line. You can either modify fusionauth.properties or environment variables.

    More info here: https://fusionauth.io/docs/v1/tech/reference/configuration



  • Regarding all the settings, yes, you'll have to set those up again. There's currently no way to export configuration of a FusionAuth setup.

    What you can do is write a Kickstart file which lets you set up a new FusionAuth instance to be configured just how you want it. You basically build a JSON file which calls the APIs to configure FusionAuth: https://fusionauth.io/docs/v1/tech/installation-guide/kickstart


Log in to reply