Login with Magic Link?



  • I am following the "Passwordless in less than 60 seconds" video. I don't have the login choice "Magic Link". Why is this?

    I also notice that in the video the user is going to Edit Application home/settings/applications/edit. I don't have this choice on my Fusion Auth. Could this be a version issue? I am on 1.19.4



  • The passwordless in 60 seconds video was recorded a while ago (on version 1.5.1). While the functionality is still all there, it lives at different places.

    Have you enabled passwordless? To do so in 1.19.x, go to Applications -> Your application -> Security and enable passwordess, then save it. This should enable the button on your applications signin form.



  • Yes, it is enabled. Any other fields that need to be set to make Magic Link appear? Does it only appear after a passwordless login email has been sent, perhaps?



  • Hmmm. I just enabled it on my local instance and the link showed up just fine.

    Screen Shot 2020-09-29 at 5.32.01 PM.png

    Are you using the hosted login pages?

    Are you passing the client id which corresponds to the application for which you have enabled passwordless login?



  • I am not using the hosted version.

    Are you passing the client id which corresponds to the application for which you have enabled passwordless login?
    Passing it in where? BTW, my "Authorized redirect URLs" option is greyed out. My Authorization Code grant is enabled. Could it be a misconfiguration of my oauthe2?



  • Sorry, when I say "hosted login pages" I mean the FusionAuth themed login pages.

    Are you using those?



  • I am not using any login pages. Where would I set that up? The plan is to eventually send a passwordless email to a user, have them click the link which brings them to a form on my host. But for now I am trying to get it to work with just the FusionAuth control panel.



  • Hi @richb201 ,

    The hosted pages are set up by default for you.

    So if I understand you correctly, are you saying that you have enabled passwordless for a given application but don't see the 'magic link' button on the login form?

    What is the "OAuth IdP login URL" value that you are trying to login with? (If you go to Applications and then click the green magnifying glass next to the application you are trying to set up, you can see this value.)

    Also, what is the value for "Passwordless login" from that same screen?



  • The oauth idp is : http://localhost:9011/oauth2/authorize?client_id=32688330-1630-4e0d-a4de-8ae45c3ca527&response_type=code&redirect_uri={your redirect URI here}

    Notice that there is no redirect.! I am not able to fill in that field on Home/ Applications/Edit because it is greyed out.



  • You need to add a redirect ("Applications" -> your application -> "OAuth" and then add a URL which can receive an authorization code and then retrieve an access token).



  • Sorry, I was moving quick last night and misunderstood your comment. What do you mean you can't edit the redirect? Can you share a screenshot, please?



  • Screenshot from 2020-10-02 13-45-28.png

    see the very bottom? Authorized redirect URLs? I can't seem to change that since it is greyed out.



  • Ah, that's a ux quirk. It isn't actually disabled, you should be able to add one or more urls to it.

    You can see how I add a redirect url here: https://youtu.be/trzY5otEgKM?t=254

    Hope that helps.



  • Thanks Dan. I watched the video. No, it will not take my redirect URL. Now, I don't have https on my laptop. Is that the issue? I am developing in a docker container on the laptop.



  • You can't paste text into that input box, you have to type it. Are you trying to paste it in, perhaps?

    If not, then there's something I don't understand going on.

    Developing in docker shouldn't affect this.

    Are you logged in as the admin user?



  • I am logged in as me and looking at the Users (attached) I am NOT an admin. Must I change that and how? BTW, my shirt came today. TY. Screenshot from 2020-10-03 18-54-05.png

    BTW, what does cat /etc/password mean?



  • Hiya,

    You are an admin (you have the admin role in the FusionAuth app) so you should be able to add a redirect URI.

    Any chance you can record and upload a video of you trying to add the redirect URI? Everything looks solid from what I can see, so I'm a bit confused about what is happening.

    Glad you got the shirt! cat /etc/passwd is unix-speak for "show my all your passwords" 🙂



  • @dan said in Login with Magic Link?:

    You can't paste text into that input box, you have to type it. Are you trying to paste it in, perhaps?

    I was wrong, you can paste it in. You just can't paste in two or more urls.



  • @dan said in Login with Magic Link?:

    You are an admin (you have the admin role in the FusionAuth app) so you should be able to add a redirect URI.

    But I am trying to use the Research Credit Toolkit application. I haven't tried it with the FusionAuth application yet. Anyway I am going to try to record a screen video. I use Screenshot which doesn't have that ability. Can you recommend an app to do the recording with?



  • Notice that when I first login to the control panel (see attached), the Smart Link is not there. Screenshot from 2020-10-06 12-37-07.png


Log in to reply