fusionauth mysql driver error

  • I have a newbie question, when installing in maintenance mode on windows, i have a backend MySQL instance with fustionauth schema created, but the setup fails with missing jar in spite of placing the MySQL jar in webinf/lib with

    2021-01-11 4:37:57.874 PM ERROR com.inversoft.maintenance.db.JDBCMaintenanceModeDatabaseService - No [MySQL] Driver found. The [Connector/J jar] may be missing or not be accessible.

    I have placed the mysql-connector-jar-8.0.21 in the webinf location. Any pointers on how i can get the app running?

  • @anotherrohit welcome to the FusionAuth community!

    Does the FusionAuth server with the issue have internet access?

    Where exactly did you place the jar file? Did you restart the FusionAuth service afterwards?


  • Since this topic was never followed up by the user and never closed I thought I would ask this question instead of opening a new topic.

    I am getting the same error after fresh installing 1.29 on my Windows VPS. I verified that the mysql-connector-jar-8.0.21 is in the webinf/lib folder. Obviously I downloaded fusionauth off the site so a network connection is available. What am I missing? What else can I check? This is happening when first connecting to Maintenance Mode.

  • Hi @dtokarz1!

    Sorry to hear that you having issues!

    Are you getting any other errors? If you have a copy of the error log, that might be helpful as well.


    It looks like this thread might be related and offer some additional clues?


  • Thanks for replying. I am following up to let you know what happened. I clean installed 1.29 and the mysql connector J file was there but I received that error. I copied the file from a known working install of fusionauth, it prompted me to overwrite the current file which I accepted but I still received that error. After troubleshooting some more I gave up and did a clean uninstall/reinstall.

    This time the mysql connector J file was not there. I copied the same file from the known working install of fusionauth and everything worked. I can't explain why but a full uninstall/reinstall and copying the mysql file fixed my issue. Maybe this can help someone else!

  • @dtokarz1

    Interesting fix. I will have to consider why your solution worked. In the end, glad that you were able to get it working!


Log in to reply